Libksieve

sieveeditorwarning.cpp
1 /*
2  SPDX-FileCopyrightText: 2013-2021 Laurent Montel <[email protected]>
3 
4  SPDX-License-Identifier: LGPL-2.0-or-later
5 */
6 #include "sieveeditorwarning.h"
7 
8 #include <KLocalizedString>
9 using namespace KSieveUi;
10 
11 SieveEditorWarning::SieveEditorWarning(QWidget *parent)
12  : KMessageWidget(parent)
13 {
14  setVisible(false);
15  setCloseButtonVisible(true);
16  setMessageType(Error);
17  setText(i18n("We cannot parse script. We cannot switch to graphical mode"));
18  setWordWrap(true);
19 }
20 
21 SieveEditorWarning::~SieveEditorWarning()
22 {
23 }
virtual void setVisible(bool visible)
QString i18n(const char *text, const TYPE &arg...)
This file is part of the KDE documentation.
Documentation copyright © 1996-2021 The KDE developers.
Generated on Sun Apr 11 2021 23:09:36 by doxygen 1.8.11 written by Dimitri van Heesch, © 1997-2006

KDE's Doxygen guidelines are available online.